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Workflows   

A workflow is most easily defined as a group of related screens. When you open any 

personnel record, you are viewing the standard workflow, which is the group of screens that 

all share the purpose of organizing your personnel. However, the screens in workflows do not 

need to have any relation or common purpose. Any screen may be added to a workflow, be it 

custom or standard. Any electronic form can also be added to a workflow. 

Suppose you wanted to view your employee’s Compensation screen as well as a custom 

screen displaying the employee’s previous job training. These screens are obviously not in 

the same context, but if your job requires viewing both of these screens, a workflow can be 

made that accommodates them. 

Custom workflows are most useful when you want to group together several custom screens. 

The custom screens can be grouped together using the Workflows option on the Tools menu. 

Once you have created a workflow, you can then view it under the Workflows menu. You 

can even replace the standard workflow with a custom workflow, if a custom workflow better 

suits your needs.  

The Workflows screen provides a list of the current workflows on the left and a data entry 

area to the right. A Menu Bar and a Tool Bar are provided to enable you to fully manage your 

list of workflows. The Workflows process uses a three-tab screen. 

Workflow Setup Tab  

The Workflow Setup tab allows you to name the worflow, assign it to a categor, and specify 

important workflow details. Details for the workflow and their descritions are defined below. 

Default Action  
The default action when opening this workflow, which can be either open an existing record 

or create a new record. 

Show on Menu  
A check box that allows you to specify whether or not the current workflow should be shown 

on the Workflows menu. Select this check box to show the workflow on the Workflows 

menu. Clear this check box to not show the workflow on the Workflows menu. This field is 

defaulted as selected. 

Allow New Record  
A check box that allows you to specify whether or not users can add a new record while in 

this workflow. Usually it is wise to let users add new records in any workflow. However, you 

may want to regulate the addition of new records, especially in sensitive workflows that deal 

with compensation and salaries. Select this check box to allow users to add a new record or 

clear the check box to not allow users to add a new record. 

Suppress Toolbar 
A check box that allows you to specify whether or not users can access the toolbar while in 

this workflow. This will hide the tool bar.  This can be used for workflows with any type of 

screen, but is normally used for "text-only".  If the user creates a multi-screen workflow with 
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suppressed toolbars, the user will need to add the capability to move between the screens. 

Likewise for moving between records. 

Save Transaction History  
A check box that allows you to specify whether or not the transaction history for this 

workflow should be saved. Select the check box to save transaction history, which in effect is 

like auditing all fields used on the workflow. Clear the check box to not save transaction 

history. If you choose to save transaction history for a workflow, this history is available for 

viewing in a record by using the Show Transaction History button on the Navigation Bar or 

by using the Audit/Transaction History process on the Administration menu. 

Link History to Notes  
A check box that allows you to specify whether or not to link transaction history to notes and 

is only relevant if the Save Transaction History check box is selected. Select the check box to 

link transaction history to notes. Clear the check box to not link transaction history to notes. 

If you select the check box, a note with a Note Text of “Transaction History Link” is added to 

the record when it is saved, and this note has an attachment, which links to the appropriate 

transaction history. This allows you to easily link to the relevant transaction history. If you 

choose not to link history to notes, you still have access to that history using the Show 

Transaction History button when in that record. 

Save Document to Notes  
A check box that allows you to specify whether or not to save the document (specified in the 

Document to Attach field) to notes. Select the check box to save the document to notes. Clear 

the check box to not save the document to notes. If you select the check box, a note with a 

Note Text of “Workflow: workflow name History Document” is added to the record when it 

is saved, and this note has the specified document as an attachment. This allows you to have a 

snapshot of the data at the time the record is saved. 

Document to Attach  
The document to attach to notes when the Save Document to Notes check box is selected. 

This field is supported by the Select Document popup. 

Record Group  
The group type to use when the document is generated. Current Group will show the 

information for the current record group; whereas Current Record will show only the current 

record’s information on the document. A record type of Use Query allows you to use the 

query from the document to determine the records to use for the document. Choosing the 

current record or current group ignores the document’s query. 

Screens Tab 

The Screens tab allows you to select which screens you want on the selected workflow. Any 

screen in the current module may be added to a workflow, including custom screens. 

Change the Default Workflow 

The default workflow is the workflow that is displayed when you use the File menu options 

or Shortcut Bar icons. People-Trak is shipped with workflows named “Standard-” followed 

by the type of record being updated by the workflow. For example, the standard workflow for 

the Personnel Management is “Standard-Employee”. 
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You can change the default workflow per module for a user in User Setup. Any valid 

workflow can be chosen.  

Accessing Workflows 

Workflows can be accessed in several different ways as described below. After the workflow 

has been accessed, it is opened using the default action specified in the Default Action field 

of the workflow and the records can be processed accordingly. 

As Default Workflow 
If the workflow is the default workflow for a user, the user need only use the New or Open 

Record option on the Shortcut Bar or the File menu to access that default workflow. 

On Workflows Menu 
If the workflow has the Show on Menu check box selected, it will appear on the Workflows 

menu, and the user can then select it from that menu. 

In Organizer Categories Pane 
The workflow is included within its assigned category in the Organizer desktop’s Categories 

pane. The user can then select the workflow from the list of workflows in the Workflows 

subcategory of that main category. 

In Organizer Tasks Pane  
If the user has the workflow in the list of their Desktop Tasks in User Setup, the user can 

select the task in the Tasks pane of the Organizer desktop. 
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Notes 
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This lesson covers how to create and access a workflow as well as how to allow new records 

to be added using the workflow. 

Tutorials 
Basic Setup: shows how to set up a new workflow and then access it from the Organizer 

desktop. 

Adding a Workflow to Desktop Tasks: demonstrates how to add your workflow to the 

desktops tasks that are available on all desktops. 

Allowing New Records: shows how to allow a user to add new records from within your 

workflow. 
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Tutorial 1.1 – Basic Setup 

Workflows are a collection of one or more screens. In prior lessons, we have used the 

Workflows feature to demonstrate how custom screens can be displayed. In this tutorial, we 

will look at some basic setup options. 

1. On the Tools menu, select Workflows.  

 

The Workflows screen is displayed. The Workflows screen is a tabbed screen that 

provides a list of the current workflows on the left and a data entry area on the right. The 

Workflow Setup tab is for specifying basic settings and the Screens tab is used to specify 

the screens to be used in the workflow. A Menu Bar and a Tool Bar are provided to 

enable you to fully manage your list of workflows. Let’s get started and create a 

workflow. 

2. On the File menu, select New Workflow or on the Tool Bar, click the New Workflow 

button to create a new workflow.  

 

A default name will be assigned. The name is NEW-#, where “#” is the next available, 

unused number. 

3. Change this default name to My Workflow.  

 

Do not worry about wasting keystrokes. We will not delete this workflow in two seconds 

just to make a point. Now let’s start learning some good stuff. 

 

As with custom screens, the Category field is used for security. With workflows, it also 

determines where the workflow is displayed in the Categories pane of the desktop. The 

Category is defaulted to User but can be changed to any of the pre-defined categories. 

4. In the Category field, select Personal. 

5. Click the Screens tab. In the Screen Name field, use the popup button to display a list of 

screens and select the Personal screen.  

 

We now have the basis for a workflow. We have a name and we have a screen. Let’s do 

something with it. 

6. Close the Workflow screen, saving your changes. 

 

Now, let’s find your workflow.  

7. Check the Workflows menu.  

 

Is it there? Yes, because new workflows default to having the Show on Menu check box 

selected. If you don’t want the workflow to show up on the Workflows menu just clear 

that check box. 

8. Go ahead and select your workflow. 

 

The Lookup Employee screen is displayed. This is because the default action for the 

workflow is to open a record. 

9. Select any records so you can see your workflow in action. 
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Once your workflow is opened with those records, note that the Screen dropdown shows 

the Personal screen, but it is grayed out. This is because you only have one screen, 

Personal, assigned to this workflow. You can’t use the dropdown to switch to other 

screens because there aren’t any. 

10. Now close your workflow. 

 

Let’s take a look at another default action for your workflow. 

11. On the Tools menu, select Workflows. Select your My Workflow workflow. 

12. In the Default Action field, select New. Close your workflow, saving your change. 

13. Find the Personal category in the Categories pane. Open the category and then open the 

sub-category for Workflows. Your workflow should be there because you assigned it to 

the Personal category. Go ahead and select your workflow by clicking on it. 

 

The Create Employee screen is displayed because you set the Default Action for your 

workflow to New. 

14. Click Create to create a new employee record from scratch. 

 

Your workflow is displayed, and a new record was created. 

15. On the File menu, select Delete Employee and delete the record just created. 

 

This deletes the record and closes the workflow since that was the only record open. 

 

Now, let’s set your workflow back to the Open action. 

16. On the Tools menu, select Workflows. Select your My Workflow workflow. 

17. In the Default Action field, select Open. Close your workflow, saving your change. 

 

As we have seen, you can select workflows from the menu or from any organizer 

category you specify. However, you do not have to do both, and in fact, you do not have 

to do either. You may be wondering why you would create a workflow that does not 

show up anywhere. There is actually a very important place that we can put this 

workflow. Let’s illustrate this point in the next tutorial.  

18. Continue with the next tutorial. 
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Tutorial 1.2 – Adding a Workflow to Desktop Tasks 

In the last tutorial, you saw how your workflow was accessed from the Organizer desktop 

both from the menu and the Categories pane.  Now, let’s see how to add your workflow to the 

tasks available on all desktops. 

1. On the Tools menu, select Workflows and select My Workflow. Clear the Show on 

Menu check box. Close the Workflows screen, saving your change. 

 

That option is no longer listed on the Workflows menu, but is still listed in the Categories 

pane. Now let’s learn something new. 

2. In the Tasks pane, open the My Workflows category.  

 

There is a list of workflows there, but your workflow is not one of them. Let’s add it. 

3. On the Setup menu, select User Setup. Do not change the current user, which would be 

you, DEMO. Click the Preferences tab.  

4. Select the Define Tasks button. 

We want to add our new workflow to the group of tasks already in the My Workflows 

category, so we need to add that task in that location. 

5. Scroll down and click on the first task in the My Workflows category. Insert a row at 

that location. In the Group column, use the popup to select the My Workflows group 

6. In the Module column, use the popup to select the Personnel Management module. 

7. In the Task Type column, use the popup to select the Edit task type. 

8. In the Task Name column, use the popup to select your My Workflow workflow.  

9. Close the Desktop Tasks screen saving your changes. 

10. Close the User Setup screen, saving your changes.  

11. In the Tasks pane, open the My Workflows group.  

 

Note that the list of tasks has been updated to include your workflow. You may recall the 

great feeling you had when you selected your workflow from the Workflows menu and 

from the Categories pane. You can now have that same feeling again by selecting your 

workflow from your list of favorites.  

12. Click on your workflow to open it, open any record, enjoy the accomplishment and then 

close your workflow. 

You have now learned that the workflows you create, such as the simple workflow just 

created and the complex workflows we will create soon, can be selected from the 

Workflows menu, from a specified category in the Organizer desktop, or from the list of 

tasks available on the Tasks pane. So many choices! 

13. Continue with the next tutorial. 
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Tutorial 1.3 – Allowing New Records 

First, let’s take care of some housekeeping chores.  

1. Return to your Organizer desktop. 

2. On the Tools menu, select Workflows and then select your My Workflow workflow. 

Select the Show on Menu check box so that we can demonstrate some new features.  

 

Now, we’ll learn about the Allow New Record feature. 

 

There are times when you wish to allow a user to add new records from within a 

workflow and there are times when you do not. Let’s demonstrate. 

 

The Allow New Record is defaulted to selected when a new workflow is created, so it 

should already be selected. 

3. Close the Workflows screen, saving your changes. On the Workflows menu, select your 

workflow and open any records. Open the File menu and see that the New Employee 

option is present. Check the Tool Bar and the New Employee button is present. Close 

your workflow. 

4. Select your workflow for modification and clear the Allow New Record check box. 

Close the Workflows screen, saving your changes. On the Workflows menu, select your 

workflow and open any records. This time, the New Employee menu option and Tool 

Bar button are not present. 

5. Close the record group. 

6. Select your workflow for modification.  

7. Select the Allow New Record check box. 

 

We demonstrated this feature with the Default Action set to Open. If you have the 

Default Action set to New, it is obvious that new is allowed in the workflow at any time.  

8. Verify that the Save Transaction History check box is not selected.  

 

We are learning about this next. 

9. Close the Workflows screen, saving your changes.  

10. This concludes this tutorial and lesson. 
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Notes 
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This lesson covers some advanced features when working with workflows. 

Tutorials 
Saving Transaction History for a Workflow: shows you how to save transaction history for 

a workflow. 

Multi-Screen Workflows: demonstrates how to create multi-screen and complex workflows. 

Changing the Default Workflow: demonstrates how to change the default workflow for a 

module. 
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Tutorial 2.1 – Saving Transaction History for a Workflow 

When creating workflows, there are times when you would like to audit all of the fields 

without touching other audit settings. You just want fields changed on this workflow to be 

audited. For example, you may create a custom screen for salary changes to be submitted by 

managers. You may not normally be auditing the salary fields because these are changes you 

make. However, you do wish to audit these fields if recorded on this particular custom screen 

in a particular workflow. You can do exactly this and more by saving the transaction history 

for a workflow. You learned about this when using a standard workflow in the 

Administration training, but we will now demonstrate how all this works when there are also 

custom workflows. 

1. On the Setup menu, select Audit Setup. Select the Personal category. If there are any 

check boxes selected, click the Toggle all fields on this screen button to toggle all of the 

fields so they will not be audited. This means that no fields will be checked. 

2. Select the City check box. We want only the City field to be audited. Close the Audit 

Setup screen, saving your changes. 

3. On the Workflows menu, select your My Workflow workflow. Open Donald Stern’s 

record. In the Address frame, change all of the address fields. Use any values you desire, 

but change all of the fields in that frame. 

4. When you have updated the address fields, click the Save button to save all of these 

changes without leaving Donald’s record.  

 

The color of the fields should change to reflect the save. 

5. On the Audit menu, select the Audit History menu option. 

 

Note that the change to Donald’s City field is reflected in the list, but that the other 

changes are not. This is because only the City field was selected for auditing.  

6. Close the Field Audit History screen. 

7. On the Audit menu, select the Transaction History menu option. 

 

There is no transaction history for Donald because we aren’t yet saving transaction 

history for any workflows, including yours. Let’s save transaction history for your 

workflow now. 

8. Close Donald’s record.  

9. On the Tools menu, select Workflows and then select your My Workflow workflow. 

Select the Save Transaction History check box.  

 

When you save transaction history for a workflow, you also have the option of adding a 

link to that transaction history in the notes for the record being updated. We’ll 

demonstrate that as well. 

10. Select the Link History to Notes check box. 

 

Below that check box is the Save Document to Notes check box. You can select that at 

any time, you do not have to be saving transaction history. Since we are going to be 

taking a look at notes in a bit anyway, let’s also demonstrate how this works. 
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11. Select the Save Document to Notes check box. 

 

When this check box is selected, you must select a document in the Document to Attach 

field. This document will typically contain data that you want to see a snapshot of at the 

point in time changes to the record are saved. 

12. In the Document to Attach field, use the popup and select any document. 

13. Close the Workflows screen, saving your changes. 

14. On the Workflows menu, select your workflow and then open Donald Stern’s record. 

Change all of Donald’s address fields and then save the changes without leaving 

Donald’s record. 

15. On the Audit menu, select the Audit History menu option. 

 

This time you will find that all of the fields have been audited, and the most recent 

change is listed at the top. 

 

The Save Transaction History setting has audited all fields. Saving transaction history 

saved audit information for all fields on that workflow, not just those set to auditing in 

Audit Setup. Saving transaction history also captures key transaction history as well. 

Let’s take a look. 

16. Close the Field Audit History screen. 

17. On the Audit menu, select the Transaction History menu option. 

 

The Transaction History screen is displayed, and you can now see My Workflow listed in 

the workflow listing. Since your workflow is the only one, it is automatically selected. 

The transaction history for the changes we just made using your workflow are displayed 

in the Changes grid. 

18. Close the Transaction History screen. 

19. On the Category Bar, click the Category Notes button. 

 

The Notes for Personal category are displayed, and you should see a Transaction History 

Link entry for today’s date with an attachment. This note was created because you 

selected the Link History to Notes check box. It was created in the Personal category 

because that is the category you assigned to your workflow. 

20. Click anywhere in that Transaction History Link row, and then click the Show button. 

 

The Transaction History screen is displayed with the changes you just made. 

21. Close the Transaction History screen. 

 

You should also see a History Document note for your workflow.  

22. Click anywhere in that History Document row, and then click the Show button. 

 

The document you selected is displayed. When you saved your changes, this document 

was generated to a pdf file and stored with this note. You now have the snapshot of data 

at that point in time. 
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23. Close the Document Viewer.  

24. Close the Notes for Personal Category screen. 

25. Make another change to Donald’s record and click the Save button to save that change. 

26. Select Transaction History on the Audit menu. 

 

Now you will see two transaction entries for your workflow, with the most recent 

transaction on top and highlighted. You will also see the change you just made in the 

Changes grid. Every time you save, there is a new transaction created. 

27. Close the Transaction History screen. 

 

As we have seen the Save Transaction History setting has overridden the standard audit 

settings for the address fields, but only on this workflow. Let’s illustrate this. 

28. Close Donald’s record and then open it again by clicking the Open Employee shortcut to 

use the Standard - Employee workflow, not your workflow. Change a few address 

fields, save the changes and then check the audit history.  

 

The audit history will only show a change for the City field. That is because the audit 

override set on your workflow only applies to changes made within that workflow. We 

did not make this change on the Standard - Employee workflow and thus the settings 

made within the Audit Setup process apply, which is to audit the City field only.  

29. Close the Field Audit History screen and close Donald’s record. 

30. Continue with the next tutorial. 
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Tutorial 2.2 – Multi-Screen Workflows 

Thus far, we have been demonstrating workflow features using very simple workflows. You 

are not limited to simple workflows. You can create workflows with many screens and a few 

twists.  

1. On the Tools menu, select Workflows and then select your My Workflow workflow. 

Click the Screens tab. You already have the Personal (EMP-1) screen on your 

workflow, so add EMP-2, EMP-3, and up through EMP-6 using the Screen Name 

popup sorted by Screen Code. Once you have these screens added, select EMP-8, EMP-

9, and EMP-12. You should have a total of 9 screens on your workflow when you are 

done. 

2. Close the Workflows screen, saving your changes.  

3. On the Workflows menu, select your workflow. Open Donald Stern’s record and move 

through the screens.  

 

If this workflow looks a lot like the Standard - Employee workflow, it should. You 

recreated this workflow when you selected each of the main screens.  

4. Close your workflow. 

 

Now let’s modify your workflow again. This time, let’s assume that you are a Training 

Coordinator and you only wish to see screens pertinent to the training process.  

5. Modify your workflow again and change the list of screens to include only 

Training/Competency (EMP-8). Close the Workflows screen, saving your changes. 

6. Now, acting as the Training Coordinator, select your new workflow, open any records 

and admire the fact that you have a workflow designed just for you. 

 

Life is good, but it can be better. You may not wish to have to remember to go to the 

Workflows menu to get your workflow. Why can’t your workflow be the one that always 

shows up and not the Standard - Employee workflow? Good news! It can, but we’ll learn 

that in the next tutorial.  

7. Close the workflow and read on. 

 

Thus far, we have only selected main screens on your workflow. These are the screens 

that are not selected with buttons from other screens. However, you are not limited to 

doing so. If you see a screen name available in the list, even one that is normally used as 

a sub screen or one that you have made yourself, you can use it. 

8. Select your workflow for modification. On the Screens tab, add the following screens: 

EMP-8A, EMP-8B, EMP-8C, and EMP-8D.  

 

These are the sub screens normally displayed on the larger Training screen. Let’s see how 

it looks.  

9. Close the Workflows screen, saving your changes. On the Workflows menu, select your 

workflow. Open any record and then move through the screens.  

 

The screens that are used as sub screens in the Standard - Employee workflow work 
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perfectly as non-sub screens in your workflow. You can mix and match these screens in 

any combination you desire including using the same screen twice, as you will see. 

10. Select the Training/Competency screen.  

 

This screen should have a stack of buttons on the right side. One of these buttons has the 

caption Certifications. The Certifications screen is used to record certifications an 

employee has earned upon successful completion of a training course. In your workflow, 

the Certifications screen is used both as a sub screen called from the Training screen and 

as a main screen later in the set. 

11. Click the Certifications button to display the Certifications sub screen. In the 

Certification Code field, use the popup button to select a certification. After your 

selection, the Certification Name and the State should be returned. Close the sub screen, 

saving your changes. 

12. Now move through the screens until you reach the Certifications screen used as a main 

screen. 

 

Note that the exact same change is displayed there. This screen reflects exactly the same 

work that was keyed on the sub screen earlier.  

13. Add another certification on this “main” screen and then return to the sub screen used 

earlier.  

 

The sub screen will reflect both changes because a screen is a screen is a screen. 

14. Close the workflow. 

15. Continue with the next tutorial. 
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Tutorial 2.3 – Changing the Default Workflow 

In any module, users can have their own “default” workflow. The default workflow is not the 

same as the “standard” workflow. The Standard - Employee workflow is the workflow that 

People-Trak provides when the product is shipped. The default workflow is the workflow that 

will be used when you choose the New Record or Open Record option on the File menu or on 

the Shortcut Bar. The default workflow is the one that always displays unless you specifically 

select a different workflow from the Workflows menu or the Organizer. Let’s change your 

default workflow now. 

1. On the Setup menu, select User Setup. Click the Default Workflows tab. 

 

Note that the default workflow listed in the grid for the Personnel Management module is 

the Standard - Employee workflow.  

2. In the Workflow Name column for the Personnel Management module, click the 

popup button to display a list of the available workflows. Select your workflow, which is 

now composed of training screens only. Close the User Setup screen, saving your 

changes. 

 

Let’s see how it worked.  

3. Click the Open Employee shortcut and select Donald Stern.  

 

Rather than the boring old Standard - Employee workflow, you should now see your 

workflow.  

4. Close your workflow and use the File menu to open an employee.  

 

Again, you should see your workflow. It’s that simple: your workflow has taken over the 

world.  

5. Close your workflow and keep learning. 

6. Return to the User Setup process and change your default workflow back to the 

Standard - Employee workflow.  

 

This will help us in future tutorials.  

7. This concludes this tutorial and lesson.  
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Notes 
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This lesson covers how to create a custom screen that uses a form as a background image, 

which allows you to easily create electronic input forms. It concludes with suppressing the 

default toolbar in a workflow and creating a custom one to replace it. 

Tutorials 
Select a Form and Position Fields: shows how to select a form and then position fields on 

that form. 

Using the Form in a Workflow: demonstrates how to add the form to a workflow. 

Suppressing a Workflow Toolbar: shows how to suppress a toolbar from within your 

workflow. 

Create the Button Triggers: demonstrates how to create the button triggers required for the 

custom screen. 

Build and Use the Custom Toolbar: shows how to build and use the custom toolbar you 

created. 
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Tutorial 3.1 – Select a Form and Position Fields 

You have already created a custom screen with a background image. Now you will create a 

custom screen with a PDF form as its background. This gives you the ability to create a form 

that can then be used for data entry.   

The first steps in creating this type of form are to select the PDF form to be used and pick the 

fields that are to be input using the form. This should look very familiar to you after having 

learned about form templates in past training. 

1. On the Tools menu, select Custom Screens. 

 

The Custom Screens screen is displayed.  

2. On the File menu, select New Custom Screen or on the Tool Bar, click the New Custom 

Screen button to start a new custom screen.  

 

A default name will be assigned. The name is NEW-#, where “#” is the next available, 

unused number. 

3. Change the name of the custom screen to Employee Information Form. 

4. In the Category field, select Personal. 

 

Now, let’s select the PDF form we want to use.  

5. Click the Select Form/Image button to display the Select File screen that works just like 

Windows Explorer.  

6. In the PT9\SAMPLES directory of your local People-Trak drive, select the file named 

APPLICANT INFORMATION 1.PDF.  

7. Click the Preview button and take a look at the form so far, noting the format and the 

fields that need to be filled in. 

8. Close preview mode for now, but we’ll return when we have some objects to manipulate. 

 

At this point, you would normally start selecting the fields you need for your form by 

looking at the form. We will save you some time and provide a list of the fields needed. 

9. Select the following Field Names: 

 

Last Name  

Middle Name 

First Name 

Address 1 

Address 2 

City 

State 

Zip Code 

Home Phone 

Birth Date 

 

Now we need to place these fields in their respective positions on the form. We’ll start by 

entering preview mode.  
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10. Click the Preview button. 

 

The names of the fields you have placed on the form are listed in the Object dropdown. 

The fields themselves are listed down the left side of the form. We are now ready to 

begin moving these fields into their respective places on the form. We want to move the 

field and its caption together. Remember that we do that by right-clicking on the object 

itself, which also selects the caption. 

11. Right-click on the Last Name field to activate that field and its caption for movement. 

Then drag the field into its respective place on the form. Remember, you can use the 

nudge feature to move or size the field one pixel at a time.  

12. Now position the rest of the fields. 

13. Close preview mode.  

 

All we need to do is clear the captions for all our fields. 

14. For each of the Field objects, clear the Caption field. 

15. Click the Preview button. 

 

Now the form looks much better. 

16. Close preview mode. 

Note: The form we used accommodated all of our People Trak fields without needing to 

edit the actual form. There may be an instance where a company form may include fields 

that are formatted differently. For example, many forms have fields such as Gender, 

Ethnicity, US Citizen and Veteran that have multiple selections or checkboxes. These 

fields in People-Trak are a single field. Contact your Support Representative if you need 

assistance customizing a form or converting it to PDF format. Most government forms 

are now available in PDF form. 

17. Continue with the next tutorial 
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Tutorial 3.2 – Using the Form in a Workflow 

Now that you have your form-based custom screen created, let’s use it in a workflow. 

1. On the Tools menu, select Workflows. On the Tool Bar, click the New Workflow button 

to create a new workflow. Change the name of the workflow to Employee Info Form. 

Leave the Show on Menu check box selected so that this workflow will show up on the 

Workflows menu.  

 

We need to add your new custom screen to the workflow.  

2. Click the Screens tab. In the first row of the Screen Name column, click the popup 

button to display a list of the available screens. Select Employee Information Form. 

Close the Workflows screen, saving your changes. 

3. Open the Workflows menu. Your new workflow should be present. Select the workflow 

and then open all employee records. 

 

The new custom screen is displayed for the first employee with all of the information 

placed in the appropriate place on the form. Move through the list of records and note 

how the information for each employee is shown. 

 

The form that we created is longer than the space provided for normal data entry screens. 

Therefore, scroll bars are automatically activated.  

4. Use the scroll bar now to scroll the form. 

5. Close the records. 

 

There you have a single-screen workflow using your form. There are times that you 

might have a multi-page form that you want to use for input. Let’s create another simple 

form. 

6. On the Tools menu, select Custom Screens. 

7. Create a new custom screen named Employee Information Form 2. 

8. In the Category field, select Personal. 

 

Let’s select the PDF using the same method as before.  

9. Click the Select Form/Image button to display the Select File screen. 

10. In the PT9\SAMPLES directory of your local People-Trak drive, select the file named 

APPLICANT INFORMATION 2.PDF.  

To save time, we won’t be adding any fields to this new screen. 

11. Click the Preview button. 

12. Close preview mode and custom screens, saving your changes. 

13. On the Tools menu, select Workflows. Select the Employee Info Form workflow that 

you created earlier in this tutorial.  
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14. On the Screens tab, insert the Employee Information Form 2 screen below the 

Employee Information Form. 

Note that the list of screens is actually the two pages of the application form. When you 

create your own forms, you are not limited to two pages; you can have as many as are 

needed. Each page, however, must be a separate custom screen. 

15. Close the Workflows screen.  

16. Return to the Personnel Management module.  

 

We have one more thing to learn about using forms in workflows.  

 

In People-Trak, a screen is a screen is a screen. It does not matter if the screen is based on 

a form or is just a regular screen. We can actually make a workflow that is composed of 

both. While this may not be something you wish to do, it can be done. 

17. On the Tools menu, select Workflows. Select the Employee Info Form workflow that 

you created earlier in this tutorial.  

 

Now, let’s add some screens. 

18. On the Screens tab, insert the Personal screen above Employee Information Form.  

 

You should now have a workflow composed of two form based screens and one based on 

a regular screen. (And interestingly, some of the same fields are present on both the form 

and the regular screen.) 

19. Close the Workflows screen, saving your changes. Now select your Employee Info 

Form workflow from the Workflows menu. Select Donald Stern’s record and move 

through the screens. 

 

Note that the display switches between regular screens and forms instantly and that the 

scroll bars are turned on and off as necessary.  

20. Select the Personal screen. Change Donald’s Last Name to Sternz. Now move to the 

form where the last name is also displayed. 

 

Note that the name is displayed as Sternz even though it was not keyed on the form. The 

regular screen and form screen types are merely a collection of fields that reflect the 

current state of the fields placed on them. In this case, the Last Name field is Sternz at the 

moment, and it will be Sternz on any screen in any workflow until changed or deleted. 

21. Change Donald’s Last Name back to Stern.  

22. Close the record, saving your changes. 

23. On the Tools menu, select Workflows. Select the Employee Info Form workflow. 

24. On the Screens tab, delete the Personal screen from the workflow.  

25. Close the Workflows screen, saving your changes.  

26. Continue with the next tutorial.  
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Tutorial 3.3 – Suppressing a Workflow Toolbar 

In past training, we were able to see how changing security settings affected the look and 

functionality of the toolbar. Additionally, we learned how certain functions were disabled 

when they were not applicable. For example, the four grid buttons may be disabled because a 

field is not in a grid. What we have yet to explore is a feature that completely removes a 

toolbar from a workflow and suppresses the toolbar functions. In this tutorial, we will take a 

look at how toolbar suppression can affect the use of a workflow. 

Let’s take another look at our latest workflow. 

1. Select your Employee Info Form workflow from the Workflows menu. 

2. Open Donald Stern’s record. 

You should be quite familiar with the different functions of the toolbar by now. 

Remember that each button on the Tool Bar has a graphical icon on it that helps denote 

what it is, the Navigation Bar contains features for navigating groups of records and the 

Category Bar contains the Screen dropdown for navigating the various screens. 

With that quick refresher under our belts, let’s see what happens when we suppress the 

toolbar. 

3. On the Tools menu, select Workflows.  

4. Select the Employee Info Form workflow. 

5. Select the Suppress Toolbar check box. 

6. Close the Workflows screen, saving your changes. 

7. On the Workflows menu, select your workflow and open any record. 

With the toolbar gone, our workflow has turned into a single screen display. We cant 

navigate to different records or screens, we are unable to undo any editing we may decide 

to do, and any changes we make cannot be saved.  

However, we can resolve this by creating our own toolbar, complete with our own icons 

and standard functions. Before we get started, let’s restore the toolbar for our workflow. 

8. Close the Employee Info Form workflow. 

9. On the Tools menu, select Workflows.  

10. Select the Employee Info Form workflow. 

11. Click the Suppress Toolbar checkbox so that it is no longer selected. 

12. Close the Workflows screen, saving your changes. 

13. Continue with the next tutorial.  
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Tutorial 3.4 – Create the Button Triggers 

Our custom toolbar is going to use button triggers, so let’s create those first. 

1. On the Tools menu, select Button Triggers. 

2. On the File menu, select New Button Trigger or on the Tool Bar, click the New Button 

Trigger button. 

3. Enter New Previous Screen for the Trigger Name and place it in the Personal category. 

Set the Caption to Previous Screen.  

4. Click the Actions tab. 

5. Add an Execute Tool action. In the Detail for that action, select Previous Screen in the 

Tool Name field. 

6. Create another new button trigger, and enter New Next Screen for the Trigger Name 

and place it in the Personal category. Set the Caption to Next Screen. 

7. Click the Actions tab. 

8. Add an Execute Tool action. In the Detail for that action, select Next Screen in the Tool 

Name field. 

9. Create another new button trigger, and enter New Previous Record for the Trigger 

Name and place it in the Personal category. Set the Caption to Previous Record. 

10. Click the Actions tab. 

11. Add an Execute Tool action. In the Detail for that action, select Previous Record in the 

Tool Name field. 

12. Create another new button trigger, and enter New Next Record for the Trigger Name 

and place it in the Personal category. Set the Caption to Next Record. 

13. Click the Actions tab. 

14. Add an Execute Tool action. In the Detail for that action, select Next Record in the Tool 

Name field. 

15. Create another new button trigger, and enter New Close for the Trigger Name and place 

it in the Personal category. Leave the Caption blank because we will use a picture for 

this button.  

16. Click the Actions tab. 

17. Add an Execute Tool action. In the Detail for that action, select Close in the Tool Name 

field. 

18. Create another new button trigger, and enter New Exit for the Trigger Name and place it 

in the Personal category. Leave the Caption blank because we will use a picture for this 

button.  

19. Add an Execute Tool action. In the Detail for that action, select Exit in the Tool Name 

field.  
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20. Create another new button trigger, and enter New Save for the Trigger Name and place 

it in the Personal category. Leave the Caption blank because we will use a picture for 

this button.  

21. Add an Execute Tool action. In the Detail for that action, select Save in the Tool Name 

field. 

22. Create another new button trigger, and enter New Date Stamp for the Trigger Name and 

place it in the Personal category. Leave the Caption blank because we will use a picture 

for this button.  

23. Add an Execute Tool action. In the Detail for that action, select Date Stamp in the Tool 

Name field. 

24. Create another new button trigger, and enter New Undo for the Trigger Name and place 

it in the Personal category. Leave the Caption blank because we will use a picture for 

this button.  

25. Add an Execute Tool action. In the Detail for that action, select Undo in the Tool Name 

field. 

You can do all sorts of other actions upon saving the changes, but you will take a closer look 

at those when learning more about triggers in later training.  

26. Close the Button Triggers screen, saving your changes. 

 

Ok, the button triggers we need are raring to go, so in the next tutorial we will create our 

custom screen and use these triggers. 

27. Continue with the next tutorial.  
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Tutorial 3.5 – Build and Use the Custom Toolbar 

Using a similar approach to what we learned when we created screen header template, we are 

going to create our very own toolbar to use on workflows when the default is suppressed. 

1. Create a new custom screen. Name the screen My Toolbar and put it in the Personal 

category. Leave the Screen Type field set to Standard. 

2. On the first blank row, add a new Button object. Use the popup in the Object Name 

column to select the New Next Record button trigger we just created. Leave the Caption 

as is.  

3. Use the same process to add the following button triggers to the screen: 

New Previous Record  

New Next Screen  

New Previous Screen 

4. In the next blank row, add a Picture object. In the Object Name column, click the popup 

button and select our New Close button trigger. In the Caption column, click the popup 

button. In the PT9\SAMPLES directory of your local People-Trak drive, select the file 

named CLOSE_GREEN.GIF. 

5. Add another Picture object and select the New Exit button trigger. In the Caption 

column, select the EXIT_2.GIF file. 

6. Add another Picture object and select the New Save button trigger. In the Caption 

column, select the SAVE.GIF file. 

7. Add another Picture object and select the New Date Stamp button trigger. In the 

Caption column, select the DATE_STAMP.JPG file. 

8. Add another Picture object and select the New Undo button trigger. In the Caption 

column, select the UNDO.GIF file. 

9. Use preview mode to align the buttons  in a single row toward the top of the screen  as 

shown below: 

 

New Next Record  New Previous Record  New Next Screen  New Previous Screen 

The toolbar icons can be placed in any order that you choose. Make sure they are aligned 

with the buttons in a single row. 

Note: Some of the icons may require some resizing in order for them to fit next to each 

other. 

10. Close preview mode and save your changes.  

 

We have a new toolbar! Now, let’s use it on some screens. 

11. Select the Employee Information Form screen. 

12. Use the Insert Screen option to insert your My Toolbar screen to the current custom 

screen.  
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13. Use preview mode to confirm that you now have an Employee Information Form 

screen with a new toolbar. Save your new screen. 

14. Select the Employee Information Form 2 screen. 

15. Use the Insert Screen option to insert your My Toolbar screen to the current custom 

screen.  

16. Use preview mode to confirm that you now have an Employee Information Form 2 

screen with a new toolbar. Save your new screen. 

17.  Close the Custom Screens screen. 

18. On the Tools menu, select Workflows. Select the Employee Info Form workflow that 

you created earlier in this tutorial.  

19. Select the Suppress Toolbar check box. 

20. Close the Workflows screen, saving your changes. 

21. Open Donald Stern’s record within the Employee Info Form workflow. 

 

Note that our workflow now exhibits the custom toolbar. Let’s put it to work! 

The records buttons are used to select the previous and next records in the list. Let’s try 

these and see how they work. 

22. Click the Next Record button. 

 

Since we opened Donald’s record first, clicking the Next button brought up Gregory 

Wilson’s record.  

23. Now click the Previous Record button to return to Donald’s record. 

Besides multiple records, there are multiple screens in this workflow as well. We are 

currently on the first screen, so let’s take a look at the next one. 

24. Click the Next Screen button. 

25. Click on the Previous Screen button to return to the first screen.  

With navigation under our belts, let’s make some changes using our editing tools. 

26. Position to the Zip Code field and change Donald’s zip code to something new.  

27. Select the arrow shaped Undo icon to return the Zip Code to its former value. 

28. Change Donald’s Middle Name to Stanley.  

29. In the Birth Date field, clear his birth date. 

30. Select the Date Stamp icon to change Donald’s birthday to today’s date. (Hint: It looks 

like a calendar) 

Let’s make sure that these changes are saved to Donald’s record. 

31. Select the Save icon at the top of the form. 



Workflows 2: Advanced Features 

 

 Workflows     29 
 

32. Close Donald’s record by selecting the x shaped Close icon. 

Donald might not appreciate our editing session much as we do. Let’s make things right 

again. 

33. Open Donald’s record within the Employee Info Form workflow. 

34. Go ahead and change his Middle Name back to Edward and his Birth Date to 7/7/1951. 

35. Select the Exit button to close Donald’s record and save your changes. 

36. This concludes this tutorial and lesson 


